An unlock and untethered jailbreak for iPhone 4/4S iOS 5.0.1 firmware has been announced by the EasyRa1n.com team, which  calls it EasyRa1n 0.9.

Apple users running their devices on the iOS 5 operating system and waiting for an untethered jailbreak can now breathe easy with this much-anticipated news. But the team has reported that iPad 2 owners cannot take advantage of it because the 0.9.6rc14 version of EasyRa1n only supports the iPhone 4S, iPhone 4 (GSM), iPod touch 3G/4G and the first generation iPad.

This can be good news for jailbreakers since, according to @EasyRa1n, Apple did not patch up the hole it discovered. Those who have already upgraded to iOS 5.0.1 and now want to jailbreak and unlock their iPhone 4 device with iOS 5.0.1 can get the latest version of EasyRa1n, which is 0.9, to perform an untethered jailbreak iOS 5.0.1 for their devices.

Additionally, this will not be limited to a tethered boot, which means users will not have to reconnect their devices to their computers every time they reboot iOS devices, even though the iPad 2 is not supported. The team also reports that this has been confirmed by MuscleNerd of the iPhone Dev Team.

The Windows and Mac versions will provide an untethered jailbreak on iOS 5.0.1 and install Cydia on iDevice. Cydia enables a user to find and install software packages on a jailbroken iPhone, iPod Touch or iPad.