All iPhone 4S and iPad 2 users have been issued a final warning regarding the A5 untethered jailbreak and have been requested to upgrade to iOS 5.0.1 before Apple releases the upcoming iOS 5.1, which is just a matter of time now.

According to a Jailbreakplus report, interested users, waiting for the A5 untethered jailbreak, have been advised to upgrade to version 5.0.1 because as soon as 5.1 arrives, Apple, reportedly, will patch up with Pod2g’s corona exploit, and the A5 untethered jailbreak will only be active on iOS 5.0.1.

Note that if Apple ends up releasing iOS 5.1 before the A5 untethered jailbreak arrives, the users will be unable to jailbreak their iPad 2 or iPhone 4S later on.

A new statement from the BigBoss, Web site dedicated to iPhone news, guides and help, reads: “Apple is due to release 5.1 soon. When that happens, they will stop signing 5.0.1. This means you will only be able to restore to 5.1. 5.1 breaks the upcoming jailbreak. If you are currently a 4s owner or an ipad 2 owner, you will want to get your device to 5.0.1 ASAP. This way when the jailbreak is released, you will be able to use it. If you do not restore to 5.0.1 now, in a few days when 5.1 is out, you may never be able to get from 5.0 to 5.0.1 and only option will be to wait again.”

MUST READ: iOS 5 Untethered Jailbreak: How Will SOPA Affect Jailbreak?  

MUST READ: iOS 5 Untethered Jailbreak: iPhone 4S and iPad 2 Jailbreak Ready for Release (PHOTOS)