<!DOCTYPE html>
<html  xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://opengraphprotocol.org/schema/"> 
<head profile="http://www.w3.org/1999/xhtml/vocab"  prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<title>How To Cook A Prime Rib For Christmas In 6 Easy Steps</title>
<!--[if IE]><![endif]-->
<link rel="preconnect" href="https://ibt-mail.com" />
<link rel="preconnect" href="https://powerad.ai" />
<link rel="preconnect" href="//js.hs-scripts.com" />
<link rel="preconnect" href="//platform.twitter.com" />
<link rel="preconnect" href="https://api.pushnami.com" />
<link rel="preconnect" href="//connect.facebook.net" />
<link rel="dns-prefetch" href="//s1.ibtimes.com" />
<!--[if IE 9]>
<link rel="prefetch" href="//s1.ibtimes.com" />
<![endif]-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1, user-scalable=no" />
<meta http-equiv="x-dns-prefetch-control" content="on" />
<link rel="dns-prefetch" href="//powerad.ai" />
<link rel="dns-prefetch" href="//ibt-mail.com" />
<link rel="dns-prefetch" href="//platform.twitter.com" />
<link rel="dns-prefetch" href="//api.pushnami.com" />
<link rel="dns-prefetch" href="//js.hs-scripts.com" />
<link rel="dns-prefetch" href="//connect.facebook.net" />
<meta name="news_keywords" content="trending, prime rib roast recipe, prime rib recipes, standing rib roast recipe, cooking prime rib, how to cook a prime rib roast, best prime rib recipe, rib roast recipe, boneless prime rib recipe, how long to cook prime rib, best way to cook prime rib, p" />
<link rel="canonical" href="https://www.ibtimes.com/how-cook-prime-rib-christmas-6-easy-steps-3109100" />
<meta itemprop="url" content="https://www.ibtimes.com/how-cook-prime-rib-christmas-6-easy-steps-3109100" />
<meta itemprop="alternativeHeadline" content="How To Cook A Standing Rib Roast" />
<meta property="fb:app_id" content="263851690471857" />
<meta property="fb:pages" content="128026713884051" />
<meta property="og:type" content="article" />
<meta property="og:site_name" content="International Business Times" />
<meta property="og:url" content="https://www.ibtimes.com/how-cook-prime-rib-christmas-6-easy-steps-3109100" />
<meta property="og:title" content="How To Cook A Prime Rib For Christmas In 6 Easy Steps" />
<meta property="og:description" content="Here’s an easy recipe for Prime Rib Roast that will still delight the taste buds this Christmas. " />
<meta property="og:image" content="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/full/public/2020/12/24/prime-rib-roast.jpg" />
<meta property="og:image:secure_url" content="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/full/public/2020/12/24/prime-rib-roast.jpg" />
<meta property="og:image:height" content="1280" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="article:publisher" content="https://www.facebook.com/IBTimes" />
<meta property="article:section" itemprop="articleSection" content="Media &amp; Culture" />
<meta property="article:author" content="Lauren Dubois" />
<meta property="article:modified_time" itemprop="dateModified" content="2020-12-24T09:39:09-05:00" />
<meta property="article:published_time" content="2020-12-24T09:25:47-05:00" />
<meta name="twitter:site" content="@IBTimes" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="How To Cook A Prime Rib For Christmas In 6 Easy Steps  " />
<meta name="twitter:url" content="https://www.ibtimes.com/how-cook-prime-rib-christmas-6-easy-steps-3109100" />
<meta name="twitter:description" content="Here’s an easy recipe for Prime Rib Roast that will still delight the taste buds this Christmas. " />
<meta name="twitter:image" content="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/full/public/2020/12/24/prime-rib-roast.jpg" />
<link rel="apple-touch-icon" sizes="180x180" href="https://s1.ibtimes.com/sites/www.ibtimes.com/themes/us_ibtimes/favicons/apple-touch-icon.png" />
<link rel="icon" type="image/png" href="https://s1.ibtimes.com/sites/www.ibtimes.com/themes/us_ibtimes/favicons/favicon-16x16.png" sizes="16x16" />
<link rel="icon" type="image/png" href="https://s1.ibtimes.com/sites/www.ibtimes.com/themes/us_ibtimes/favicons/favicon-32x32.png" sizes="32x32" />
<link rel="manifest" type="webmanifest" href="https://s1.ibtimes.com/sites/www.ibtimes.com/themes/us_ibtimes/favicons/site.webmanifest" />
<link rel="mask-icon" type="image/svg" href="https://s1.ibtimes.com/sites/www.ibtimes.com/themes/us_ibtimes/favicons/safari-pinned-tab.svg" />
<link rel="shortcut icon" href="https://s1.ibtimes.com/sites/www.ibtimes.com/themes/us_ibtimes/favicon.ico" />
<meta name="msapplication-TileColor" content="#000000" />
<meta name="msapplication-config" content="https://s1.ibtimes.com/sites/www.ibtimes.com/themes/us_ibtimes/favicons/browserconfig.xml" />
<meta name="theme-color" content="#000000" />
<meta name="keywords" content="trending, prime rib roast recipe, prime rib recipes, standing rib roast recipe, cooking prime rib, how to cook a prime rib roast, best prime rib recipe, rib roast recipe, boneless prime rib recipe, how long to cook prime rib, best way to cook prime rib, p" />
<script type="text/javascript">var _sf_startpt=(new Date()).getTime();</script>
<link rel="amphtml" href="https://www.ibtimes.com/how-cook-prime-rib-christmas-6-easy-steps-3109100?amp=1" />
<meta property="author" content="Lauren Dubois" />
<script type="text/javascript">dataLayer = [{"entityType":"node","entityBundle":"article","entityId":"3109100","entityLabel":"How To Cook A Prime Rib For Christmas In 6 Easy Steps  ","entityLanguage":"und","entityCreated":"1608819947","entityStatus":"1","drupalLanguage":"en","userUid":0,"writer":"Lauren Dubois","section":"media-culture","edition":"us","language":"en","content_type":"article","pubdate":"20201224","pubmonth":"202012","page_name":"us.ibtimes\/media-culture\/articles","video":"Y","content_channel":"Christmas,Food\/Restaurant,Lifestyle,Celebrations","categories":"media-culture","source":"IBTimes","video_type":"related","layout":"web","paragraphs":"19","total_ads":"6","page_type":"article","topics":"Christmas"}];</script>
<meta name="description" content="Here’s an easy recipe for Prime Rib Roast that will still delight the taste buds this Christmas. " />
<link rel="dns-prefetch" href="https://stalesummer.com" /><link rel="preconnect" href="https://stalesummer.com" /><link rel="dns-prefetch" href="https://ccpa-wrapper.privacymanager.io" /><link rel="preconnect" href="https://ccpa-wrapper.privacymanager.io" /><link rel="dns-prefetch" href="https://query.fqtag.com" /><link rel="preconnect" href="https://query.fqtag.com" /><link rel="dns-prefetch" href="https://fqtag.com" /><link rel="preconnect" href="https://fqtag.com" /><link rel="dns-prefetch" href="https://c.amazon-adsystem.com" /><link rel="preconnect" href="https://c.amazon-adsystem.com" /><link rel="dns-prefetch" href="https://www.googletagservices.com" /><link rel="preconnect" href="https://www.googletagservices.com" /><link rel="dns-prefetch" href="https://securepubads.g.doubleclick.net" /><link rel="preconnect" href="https://securepubads.g.doubleclick.net" /><link rel="dns-prefetch" href="https://tpc.googlesyndication.com" /><link rel="preconnect" href="https://tpc.googlesyndication.com" /><link rel="dns-prefetch" href="https://pagead2.googlesyndication.com" /><link rel="preconnect" href="https://pagead2.googlesyndication.com" /><link rel="dns-prefetch" href="https://www.google-analytics.com" /><link rel="preconnect" href="https://www.google-analytics.com" /><link rel="dns-prefetch" href="https://static.chartbeat.com" /><link rel="preconnect" href="https://static.chartbeat.com" /><link rel="dns-prefetch" href="https://fastlane.rubiconproject.com" /><link rel="preconnect" href="https://fastlane.rubiconproject.com" /><link rel="dns-prefetch" href="https://ib.adnxs.com" /><link rel="preconnect" href="https://ib.adnxs.com" /><link rel="dns-prefetch" href="https://ibt-d.openx.net" /><link rel="preconnect" href="https://ibt-d.openx.net" /><link rel="dns-prefetch" href="https://cd.connatix.com" /><link rel="preconnect" href="https://cd.connatix.com" /><script type="text/javascript">var _sf_startpt = (new Date()).getTime();var timerStart = Date.now();var gdprAppliesGlobally=false;
(function(){function n(){if(!window.frames.__cmpLocator){if(document.body&&document.body.firstChild){var e=document.body;var t=document.createElement("iframe");t.style.display="none";t.name="__cmpLocator";e.insertBefore(t,e.firstChild)}else{setTimeout(n,5)}}}function e(e,t,n){if(typeof n!=="function"){return}if(!window.__cmpBuffer){window.__cmpBuffer=[]}if(e==="ping"){n({gdprAppliesGlobally:gdprAppliesGlobally,cmpLoaded:false},true)}else{window.__cmpBuffer.push({command:e,parameter:t,callback:n})}}e.stub=true;function t(a){if(!window.__cmp||window.__cmp.stub!==true){return}if(!a.data){return}var r=typeof a.data==="string";var e;try{e=r?JSON.parse(a.data):a.data}catch(t){return}if(e.__cmpCall){var i=e.__cmpCall;window.__cmp(i.command,i.parameter,function(e,t){var n={__cmpReturn:{returnValue:e,success:t,callId:i.callId}};a.source.postMessage(r?JSON.stringify(n):n,"*")})}}if(typeof window.__cmp!=="function"){window.__cmp=e;if(window.addEventListener){window.addEventListener("message",t,false)}else{window.attachEvent("onmessage",t)}}n()})();</script><script type="text/javascript">function ibtGetCookie(t){for(var n=t+"=",r=document.cookie.split(";"),e=0;e<r.length;e++){for(var i=r[e];" "==i.charAt(0);)i=i.substring(1);if(0==i.indexOf(n))return i.substring(n.length,i.length)}return""}
var hb_debug = ibtGetCookie('nw_debug')?1:0;
function nw_log(){if(hb_debug) console.log.apply(console,arguments)};
var xuaInfo=ibtGetCookie('X-UA-Info') ? JSON.split(ibtGetCookie('X-UA-Info')) : {country:'OTHER',state:'', city:'',ip:''};
nw_log("prebid_ads_xuaInfo_country", xuaInfo.country, Date.now()-timerStart);
window.gdprAppliesGlobally=false;(function(){function i(e){if(!window.frames[e]){if(document.body&&document.body.firstChild){var n=document.body;var t=document.createElement("iframe");t.style.display="none";t.name=e;t.title=e;n.insertBefore(t,n.firstChild)}else{setTimeout(function(){i(e)},5)}}}function e(t,a,o,e,r){function n(e,n,t){if(typeof t!=="function"){return}if(!window[a]){window[a]=[]}var i=false;if(r){i=r(e,n,t)}if(!i){window[a].push({command:e,parameter:n,callback:t})}}n.stub=true;function i(i){if(!window[t]||window[t].stub!==true){return}if(!i.data){return}var a=typeof i.data==="string";var e;try{e=a?JSON.parse(i.data):i.data}catch(n){return}if(e[o]){var r=e[o];window[t](r.command,r.parameter,function(e,n){var t={};t.postMessageReturn={returnValue:e,success:n,callId:r.callId};i.source.postMessage(a?JSON.stringify(t):t,"*")})}}if(typeof window[t]!=="function"){window[t]=n;if(window.addEventListener){window.addEventListener("message",i,false)}else{window.attachEvent("onmessage",i)}}}e("__cmp","__cmpBuffer","__cmpCall","__cmpReturn",function(e,n,t){if(e==="ping"){t({gdprAppliesGlobally:window.gdprAppliesGlobally,cmpLoaded:false},true);return true}else{return false}});i("__uspapiLocator")})();
(function(){function i(e){if(!window.frames[e]){if(document.body&&document.body.firstChild){var t=document.body;var n=document.createElement("iframe");n.style.display="none";n.name=e;n.title=e;t.insertBefore(n,t.firstChild)}else{setTimeout(function(){i(e)},5)}}}function e(n,a,r,e,o){function t(e,t,n){if(typeof n!=="function"){return}if(!window[a]){window[a]=[]}var i=false;if(o){i=o(e,t,n)}if(!i){window[a].push({command:e,parameter:t,callback:n})}}t.stub=true;function i(i){if(!window[n]||window[n].stub!==true){return}if(!i.data){return}var a=typeof i.data==="string";var e;try{e=a?JSON.parse(i.data):i.data}catch(t){return}if(e[r]){var o=e[r];window[n](o.command,o.parameter,function(e,t){var n={};n.postMessageReturn={returnValue:e,success:t,callId:o.callId};i.source.postMessage(a?JSON.stringify(n):n,"*")})}}if(typeof window[n]!=="function"){window[n]=t;if(window.addEventListener){window.addEventListener("message",i,false)}else{window.attachEvent("onmessage",i)}}}e("__uspapi","__uspapiBuffer","__uspapiCall","__uspapiReturn");i("__uspapiLocator")})();
window.didomiConfig = {
website: {
apiKey: 'd6a0184b-dd85-481f-8bc3-8ef121666a3b', privacyPolicyURL: 'https://corp.ibt.com/about-privacy-policy', name: 'International Business Times',
vendors: { didomi: ['google','amazon','facebook','twitter'],iab: {all: true}}, refreshOnConsent: false
},
theme: {color:'#f72210'},
integrations:{vendors:{google:{enable:true,refresh:false,eprivacy:true,passTargetingVariables:true}}},
notice: {position: 'popup',closeOnClick: false},
regulations: {ccpa:{enabled:true,lspa:false}},
user:{bots:{consentRequired:false,types:['crawlers','performance'],extraUserAgents:[]}}
};</script><script type="text/javascript">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</script><script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://stalesummer.com/v2jwa09-ea5JgtGMI8UDv_W4HlKfJLPJbfeNXviAWNmyjExu0se_D1bU_Pr8x9zyUiVxfGFG-_0hNq8v4c7qG8GBjE4T6vWc",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");</script><script src="https://ccpa-wrapper.privacymanager.io/ccpa/b048e9c3-ab54-4024-9fa6-983e6fcec56c/ccpa-liveramp.js"></script><script async="async" src="https://s1.ibtimes.com/sites/all/modules/modules-custom/fusion/fusion_ads/js/prebid.js?v=4.16" onload="console.log('prebid_ads prebid.js loaded', Date.now()-timerStart)"></script><script async="async" src="https://www.googletagservices.com/tag/js/gpt.js" onload="console.log('prebid_ads gpt.js loaded', Date.now()-timerStart)"></script><script type="text/javascript">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</script><script type="text/javascript">
<!--//--><![CDATA[//><!--
for(var fonts=document.cookie.split("advaggf"),i=0;i<fonts.length;i++){var font=fonts[i].split("="),pos=font[0].indexOf("ont_");-1!==pos&&(window.document.documentElement.className+=" "+font[0].substr(4).replace(/[^a-zA-Z0-9\-]/g,""))}if(void 0!==Storage){fonts=JSON.parse(localStorage.getItem("advagg_fonts"));var current_time=(new Date).getTime();for(var key in fonts)fonts[key]>=current_time&&(window.document.documentElement.className+=" "+key.replace(/[^a-zA-Z0-9\-]/g,""))}
//--><!]]>
</script>
<style type="text/css" media="all">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</style>
<script type="text/javascript" async="async" src="//js.hs-scripts.com/5154892.js"></script>
<script type="text/javascript" async="async" src="//platform.twitter.com/widgets.js"></script>
<script type="text/javascript" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/advagg_js/js__4doaOVrHFXWtNkAxvpJErZYJegMxIyNI_v23DlFpHaU__AdhAFZ5QAk_VrKkFUOCnxJb9ANrhuWlKf15A7QHm14M__XiWFjKoCIpGXBnLBEV6VO5BllK1Eni70YhEwwh7CFkc.js" defer="defer" async="async"></script>
<!-- HTML5 element support for IE6-8 -->
<!--[if lt IE 9]>
<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-3109100 node-type-article story standard-article lemon fontf"  data-gtm-category="IBTUS-ARTICLE">
<noscript aria-hidden="true"><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5F22G6" height="0" width="0" style="display:none;visibility:hidden" title="Google Tag Manager">Google Tag Manager</iframe></noscript><div class="page-top"><div id="" class="block block-fusion-ads"><div class="content"><div id="dfp-ad-top-wrapper" class="dfp-tag-wrapper"><div id="dfp-ad-top" class="dfp-tag-wrapper unstick unstick">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("dfp-ad-top");
});
</script>
</div></div></div></div></div><div id="block-ibtimes-header-header" class="block block-ibtimes-header" data-gtm-action="Header"><div class="content"> <header class="page-header"><div class="container-fluid flex-md ai-c jc-sb"> <time class="hidden-xs hidden-sm">Dec 24, 12:27 PM EST</time><div class="logo"> <a href="/"></a></div><div class="hidden-xs hidden-sm"> <a class="subscribe" href="/newsletter">Newsletter Signup</a></div><div class="search"> <span class="genericon genericon-search"></span><form action="" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="form-item form-type-textfield form-item-search-block-form"> <label class="element-invisible" for="edit-search-block-form--2">Search </label> <input title="Enter the terms you wish to search for." onfocus="" placeholder="Search" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" /></div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-tAacnkKnk7wQg9klIPaTYQdpLldT_KjsUSLHEUCX6CU" /><input type="hidden" name="form_id" value="search_block_form" /></div></form></div></div> <nav class="page-nav"><ul class="menu"><li class="first leaf business"><a href="/business" title="Business news, Economy, Markets, Financial News, Stock Markets, Earnings, Personal Finance">Business</a></li><li class="leaf technology"><a href="/technology" title="With text, videos, slideshows and multimedia, Technology at IBTimes.com offers news and insight about tech gadgets, games and social media as well as research and advances in science and health. ">Technology</a></li><li class="leaf world"><a href="/world" title="With text, videos, slideshows and multimedia, Politics at IBTimes.com offers news, analysis and insight about geopolitics and policies in Asia, Africa, the Americas, Europe and the Middle East. ">World</a></li><li class="leaf national"><a href="/national" title="">National</a></li><li class="leaf politics"><a href="/politics" title="">Politics</a></li><li class="leaf media-culture active-trail"><a href="/media-culture" title="With text, videos, slideshows and multimedia, Media&amp;amp;Culture at IBTimes.com offers news and insight about movies, art, books, the entertainment industry, cultural icons and travel.">Media &amp; Culture</a></li><li class="leaf opinion"><a href="/opinion" title="">Opinion</a></li><li class="leaf sports"><a href="/sports" title="With text, videos, slideshows and multimedia, Sports at IBTimes.com covers international sports with an emphasis on soccer, basketball, football, golf, baseball, tennis and hockey. ">Sports</a></li><li class="last leaf luxury"><a href="/luxury" title="">Luxury</a></li></ul> </nav> <span class="genericon genericon-menu"></span></header></div></div><div class="tabs"></div> <main><div class="container-fluid"><div id="block-ibtimes-header-breadcrumb" class="block block-ibtimes-header" data-gtm-action="Breadcrumb"><div class="content"><div class="breadcrumb-wrapper"><div class="breadcrumb"><span itemtype="http://data-vocabulary.org/Breadcrumb" itemscope=""><a href="https://www.ibtimes.com/media-culture" itemprop="url"><span itemprop="title">Media & Culture</span></a></span></div></div></div></div><div id="block-ibtimes-header-node-headline" class="block block-ibtimes-header"><div class="content"> <header class="article-header"><h1 itemprop="headline">How To Cook A Prime Rib For Christmas In 6 Easy Steps</h1> </header></div></div><div class="row"><div class="page-content col-md-8"><div id="block-system-main" class="block block-system" data-gtm-action="Main_Page"><div class="content"> <article id="node-3109100" class="node-article node node-article KonaBody node-sidebar flc" itemscope="" itemtype="http://schema.org/NewsArticle"><meta itemprop="mainEntityOfPage" content="https://www.ibtimes.com/how-cook-prime-rib-christmas-6-easy-steps-3109100"><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="International Business Times"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://s1.ibtimes.com/sites/www.ibtimes.com/themes/us_ibtimes/images/logo.png?v=1"></div><meta itemprop="url" content="https://www.ibtimes.com"></div> <header class="article-header"><div class="byline-social flex-xs flex-wrap jc-sb ai-c"><div class="byline"> By <span class="author"> <span itemtype="http://schema.org/Person" itemprop="author" itemscope=""><a href="/reporters/lauren-dubois" class="author-name" rel="author" itemprop="url"><span itemprop="name">Lauren Dubois</span></a></span> <span class="author-extra"> <a href="http://www.twitter.com/l_dubois613" class="genericon genericon-twitter" target="_blank">@l_dubois613</a> </span> </span> <br><time itemprop="datePublished" datetime="2020-12-24T09:25:47-05:00">12/24/20 AT 9:25 AM</time> <time itemprop="dateModified" datetime="2020-12-24T09:39:09-05:00"></time></div><div class="social-share flex-xs ai-c jc-fe"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.ibtimes.com/how-cook-prime-rib-christmas-6-easy-steps-3109100" class="genericon genericon-facebook-alt" target="_blank"></a> <a href="https://twitter.com/intent/tweet?text=How+To+Cook+A+Prime+Rib+For+Christmas+In+6+Easy+Steps+++https://www.ibtimes.com/how-cook-prime-rib-christmas-6-easy-steps-3109100" class="genericon genericon-twitter" target="_blank"></a> <a href="https://www.tumblr.com/share/link?url=https://www.ibtimes.com/how-cook-prime-rib-christmas-6-easy-steps-3109100" class="genericon genericon-tumblr" target="_blank"></a> <a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.ibtimes.com%2Fhow-cook-prime-rib-christmas-6-easy-steps-3109100&title=How+To+Cook+A+Prime+Rib+For+Christmas+In+6+Easy+Steps++" class="genericon genericon-linkedin" target="_blank"></a> <a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.ibtimes.com%2Fhow-cook-prime-rib-christmas-6-easy-steps-3109100&media=&description=How To Cook A Prime Rib For Christmas In 6 Easy Steps " class="genericon genericon-pinterest" target="_blank"></a> <a href="http://reddit.com/submit?url=https://www.ibtimes.com/how-cook-prime-rib-christmas-6-easy-steps-3109100&title=How To Cook A Prime Rib For Christmas In 6 Easy Steps " class="genericon genericon-reddit" target="_blank"></a> <a href="mailto:?&subject=How To Cook A Prime Rib For Christmas In 6 Easy Steps &body=https://www.ibtimes.com/how-cook-prime-rib-christmas-6-easy-steps-3109100" class="genericon genericon-mail" target="_blank"></a> <a href="#discussion" class="genericon genericon-comment scroll"></a></div></div> </header><div class="article-content"><div class="article-videoplayer hidden-print"><div class="videocontent-wrapper"><div class="videocontent"><div id="close_fusion_jwplayer" style="display:none"></div><style>.videocontent{position:relative;padding-bottom:56.25%}.tvplayer > div {position:absolute;top:0;left:0;width:100%;height:100%}</style><div class="tvplayer"></div></div></div></div><div class="article-body" itemprop="articleBody"><p>It’s safe to say Christmas 2020 won’t be the holiday everyone imagined this year, meaning that the traditional mouth-watering dishes some are used to eating each year after the presents are unwrapped are going to have to be made solo for the first time.</p><p>For Christmas dinner, that means that those who want to have either <a href="https://www.ibtimes.com/how-cook-turkey-thanksgiving-2020-7-easy-steps-3084990">a turkey</a>, <a href="https://www.ibtimes.com/how-cook-ham-christmas-2020-5-easy-steps-3105849">a ham</a> or a prime rib roast will need to roll up their sleeves and get to work in the kitchen—maybe even for the first time. Luckily, like <a href="https://www.ibtimes.com/7-holiday-cocktails-celebrate-christmas-2020-3105486">cocktails</a>, <a href="https://www.ibtimes.com/how-make-eggnog-recipes-traditional-vegan-chocolate-international-healthier-versions-3104768">eggnog</a> and <a href="https://www.ibtimes.com/how-make-christmas-cookies-2020-5-freezer-friendly-make-ahead-recipes-3099746">cookies</a>, there are certainly plenty of helpful recipes out there that will make it easier to enjoy your traditional holiday feast (and have some leftovers). Check out this easy recipe for Prime Rib (via <a href="https://www.simplyrecipes.com/recipes/prime_rib/" rel="nofollow" target="_blank">Simply Recipes</a>).</p><p><u><strong>You will need the following items:</strong></u></p><p><em>Ingredients:</em></p><div id="dfp-ad-oop2" class="dfp-tag-wrapper" style="line-height:0;margin:-10px auto;">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("dfp-ad-oop2");
});
</script>
</div><ul><li>One standing rib roast, 3-7 ribs, with bones cut away from the roast and tied back with kitchen string</li><li>Salt</li><li>Freshly ground black pepper</li></ul><p><em>Special Equipment:</em></p><ul><li>Large roasting pan</li><li>Digital thermometer</li></ul><p><strong>Roast Prep:</strong></p><script>
!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>


<script id="2d731bd539084805a840b532fab87fed">
cnxps.cmd.push(function () {
cnxps({
playerId: '31e6619b-4bfe-49be-9083-d8ec2c6b8340'
}).render('2d731bd539084805a840b532fab87fed');
});
</script>
<p>Before cooking, you need to properly prepare your roast to ensure it cooks properly. Start by removing the roast from the refrigerator three hours before starting to cook. Sprinkle with salt and let it sit, loosely wrapped in the butcher paper. It should get close to room temperature before cooking.</p><p>If the roast has not already been properly prepared by a butcher, cut the bones away from the meat and tie them back onto the roast with kitchen string, which allows for the roast to stand on the bones while cooking and also makes it easier to carve later on.</p><p><strong>Step-by-Step Recipe:</strong></p><p>1. Preheat your oven to 500 degrees F. Pat the roast dry with paper towels and sprinkle all over with more salt and pepper. Place the roast fat side up and bones side down in a roasting pan, and insert a meat thermometer into the thickest part, making sure&nbsp;it&nbsp;doesn’t touch a bone.</p><p>2. Brown the roast at 500 degrees F in the oven for 15 minutes.</p><p>3. Reduce oven temperature to 325 degrees F, and continue cooking, allowing for 11-2 minutes per pound for rare doneness and 13-15 minutes per pound for medium-rare.</p><p>4. Roast in oven until thermometer registers 115 degrees F for rare or 120-130 degrees F for medium. Check the temp an hour before you expect the roast to be done, and if cooking too quickly, lower oven temperature to 200 degrees F.</p><p>5. Once the roast is at the proper temperature,&nbsp;remove&nbsp;it from the oven and place it on a carving board. Cover it with foil and let it rest for 15-30 minutes before carving.</p><p>6. When ready to serve, cut away the strings and remove the bones, then carve.</p><p><strong>Oven Cook Times:</strong></p><p>Cook time can vary on all kinds of meats depending on size, including rib roast, but the U.S. Department of Agriculture Food Safety and Inspection Service <a href="https://www.foodsafety.gov/food-safety-charts/meat-poultry-charts#turkey-thawing" rel="nofollow" target="_blank">advises the following times</a>&nbsp;for&nbsp;roasts.</p><ul><li>4-6 lb. Bone-In roast: 23-25 minutes per pound</li><li>4-6 lb. Boneless roast: 28-33 minutes per pound</li></ul><p> <span class="figure image" itemscope="" itemtype="http://schema.org/ImageObject" itemprop="image"> <picture itemprop="contentUrl" width="1920" height="1280" class="mapping-embed lazysize"><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/embed/public/2020/12/24/prime-rib-roast.jpg 1x" media="(min-width: 1200px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/embed-md/public/2020/12/24/prime-rib-roast.jpg 1x" media="(min-width: 992px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/embed-md/public/2020/12/24/prime-rib-roast.jpg 1x" media="(min-width: 768px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/embed-md/public/2020/12/24/prime-rib-roast.jpg 1x" media="(min-width: 481px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/embed-sm/public/2020/12/24/prime-rib-roast.jpg 1x" media="(min-width: 0px)" /><!--[if IE 9]></video><![endif]--><img itemprop="contentUrl" width="1920" height="1280" class="mapping-embed lazysize lazyload" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/embed/public/2020/12/24/prime-rib-roast.jpg" alt="Prime Rib Roast" title="" /></picture><meta itemprop="url" content="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/embed/public/2020/12/24/prime-rib-roast.jpg"><meta itemprop="width" content="1920"><meta itemprop="height" content="1280"> <span class="figcaption"> <span class="caption" itemprop="caption">Follow this easy recipe for a Christmas Prime Rib roast. </span> <span class="credit" itemprop="copyrightHolder">Photo: Larry White/Pixabay </span> </span> </span></p></div></div></article></div></div><div id="block-ibtmedia-dfp-ibtmedia-dfp-belowcontent" class="block block-ibtmedia-dfp"><div class="content"><div id="M48526ScriptRootC307806"><div id="M48526PreloadC307806"> Loading...</div>
<script> (function(){ var D=new Date(),d=document,b='body',ce='createElement',ac='appendChild',st='style',ds='display',n='none',gi='getElementById',lp=d.location.protocol,wp=lp.indexOf('http')==0?lp:'https:'; var i=d[ce]('iframe');i[st][ds]=n;d[gi]("M48526ScriptRootC307806")[ac](i);try{var iw=i.contentWindow.document;iw.open();iw.writeln("<ht"+"ml><bo"+"dy></bo"+"dy></ht"+"ml>");iw.close();var c=iw[b];} catch(e){var iw=d;var c=d[gi]("M48526ScriptRootC307806");}var dv=iw[ce]('div');dv.id="MG_ID";dv[st][ds]=n;dv.innerHTML=307806;c[ac](dv); var s=iw[ce]('script');s.async='async';s.defer='defer';s.charset='utf-8';s.src=wp+"//jsc.mgid.com/i/b/ibtimes.com.307806.js?t="+D.getYear()+D.getMonth()+D.getUTCDate()+D.getUTCHours();c[ac](s);})(); </script>
</div> 
<script type="text/javascript" src="https://ibt-mail.com/view_webform_v2.js?u=t&webforms_id=12"></script>
<script async src="https://powerad.ai/script.js"></script><div class="mgid-US"></div></div></div><div id="" class="block block-fusion-ads"><div class="content"><div id="dfp-ad-bottom-wrapper" class="dfp-tag-wrapper"><div id="dfp-ad-bottom" class="dfp-tag-wrapper impview impview">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("dfp-ad-bottom");
});
</script>
</div></div></div></div><div id="block-ibtimes-article-related-stories-block" class="block block-ibtimes-article" data-gtm-action="Related_Stories"><div class="content"><div class="small-related"><div class="block-title">Related Stories</div><div itemtype="http://schema.org/WebPage" itemscope=""><div class="t"><a href="/world-readies-lockdown-christmas-3108980" itemprop="relatedLink">World Readies For Lockdown Christmas</a></div><div class="t"><a href="/christmas-eve-tv-schedule-2020-watch-these-movies-specials-dec-24-3106952" itemprop="relatedLink">What Movies Are On TV On Christmas Eve? </a></div></div></div></div></div><div id="block-ibtmedia-facebook-facebook-comment" class="block block-ibtmedia-facebook" data-gtm-action="Comments"><div class="content"><div id="discussion" class="discussion"><div class="block-title">Join the Discussion</div><div id="vuukle-comments"></div></div>
<script>
var VUUKLE_CONFIG = {
apiKey: '7cecf616-b9b1-4fc2-9f8e-7d16ef1f7494',
articleId: 3109100,
};
(function() {
var d = document,
s = d.createElement('script');
s.src = 'https://cdn.vuukle.com/platform.js';
(d.head || d.body).appendChild(s);
})();
</script>
</div></div><div id="block-fusion-lemon-ibt-shop-categories-wide" class="block block-fusion-lemon"><div class="content"><div class="block-title" id="ibt-shop-title"><a href="/shop">Shop By Category</a></div><ul id="ibt-shop-category-wide" class="row"><li class="col-fixed-6"> <a href="https://www.ibtimes.com/shop/mens-clothing-g33608.html">Menswear</a><ul><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/mens-clothing/mens-dress-shirts-l33633.html">Dress Shirts</a></li><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/mens-clothing/mens-swimwear-l33667.html">Swimwear</a></li><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/mens-clothing/mens-pants-l33614.html">Pants</a></li><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/mens-clothing/mens-outerwear-l33643.html">Outerwear</a></li></ul></li><li class="col-fixed-6"> <a href="https://www.ibtimes.com/shop/womens-clothing-g33683.html">Womenswear</a><ul><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/womens-clothing/womens-denim-l33697.html">Denim</a></li><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/womens-clothing/womens-swimwear-l33728.html">Swimwear</a></li><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/womens-clothing/handbags-l33758.html">Handbags</a></li><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/womens-clothing/womens-shorts-l33710.html">Shorts</a></li></ul></li><li class="col-fixed-6"> <a href="https://www.ibtimes.com/shop/jewelry-l33769.html">Jewelry</a><ul><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/jewelry/earrings-l33770.html">Earrings</a></li><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/jewelry/bracelets-l33771.html">Bracelets</a></li><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/jewelry/rings-l33772.html">Rings</a></li><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/jewelry/necklaces-l33773.html">Necklaces</a></li></ul></li><li class="col-fixed-6"> <a href="https://www.ibtimes.com/shop/shoes-g33776.html">Shoes</a><ul><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/shoes/mens-shoes-l33777.html">Mens</a></li><li class="shop-subcat"><a href="https://www.ibtimes.com/shop/shoes/womens-shoes-l33783.html">Womens</a></li></ul></li></ul><style>#ibt-shop-category-wide li{ font-family: "Gotham Narrow",sans-serif; font-weight: 700; }#ibt-shop-category-wide li .shop-img {border-bottom: 3px solid #999;margin-bottom: 3px;}#ibt-shop-category-wide li ul li {font-size: small;}.col-fixed-6 {width: 25%; float:left; position: relative; min-height: 1px; padding-left: 15px; padding-right: 15px;}@media (min-width:768px) {  .col-fixed-6 {width: 25%; float:left; position: relative; min-height: 1px; padding-left: 15px; padding-right: 15px;}}</style></div></div></div> <aside class="page-sidebar col-md-4"><div id="" class="block block-fusion-ads"><div class="content"><div id="dfp-ad-right1-wrapper" class="dfp-tag-wrapper"><div id="dfp-ad-right1" class="dfp-tag-wrapper impview impview">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("dfp-ad-right1");
});
</script>
</div></div></div></div><div id="block-ibtmedia-dfp-ibtmedia-dfp-right5-newsmax" class="block block-ibtmedia-dfp"><div class="content"></div></div><div id="" class="block block-fusion-ads"><div class="content"><div id="dfp-ad-right2-wrapper" class="dfp-tag-wrapper"><div id="dfp-ad-right2" class="dfp-tag-wrapper impview impview">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("dfp-ad-right2");
});
</script>
</div></div></div></div><div id="block-ibtmedia-top-stories-top-stories" class="block block-ibtmedia-top-stories" data-gtm-action="TopStories_Sitewide"><div class="content"><div class="most-popular"><ul class="most-tabs"><li><a href="#most-popular">Most Read</a></li></ul><div id="most-popular" class="most-list">
<script type="text/javascript">(function(){var script=document.createElement('script');script.type='text/javascript';script.async=true;script.src='https://cdn.feeds.ibt.com/tm-hits-widget.js?story_type=analysis%2Carticle%2Ccolumn%2Ceditorial%2Cinterview%2Cop_ed%2Copinion%2Cpulse%2Cslideshow%2Cblog_entry&created=1608571631&syndication=1&numbered=0&numbered2=1&placeholder_id=most_popular_widget&include_categories=0&exclude_cateids=1060003%7C26%7C1630%7C19%7C12%7C34%7C1060006%7C2%7C1059213%7C315%7C38%7C6%7C10%7C35%7C14&include_images=1&include_shares=0&limit=5&sponsor=&include_spons1=&include_spons2=&include_spons3=&site=www.ibtimes.com';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(script,s);})();</script>
<div id="most_popular_widget"></div></div></div></div></div><div id="block-fusion-newsletters-fusion-daily-newsletter" class="block block-fusion-newsletters"><div class="content"><div class="daily-newsletter"> <span class="genericon genericon-mail"></span>Stay up to date with our <a href="/newsletter" target="_blank">daily newsletter</a></div><style>
.daily-newsletter {
background: #f5f5f5;
border: 2px solid #e5e5e5;
color: #0e0e0e;
text-align: center;
padding: 1em 0;
margin:10px 0 20px;
}
.daily-newsletter .genericon {display:inline-block}
.daily-newsletter a {color:#13beea;border-bottom-width:2px;border-bottom-style:solid;}
.daily-newsletter a:hover {border-bottom:none}
</style></div></div><div id="" class="block block-fusion-ads"><div class="content"><div id="dfp-ad-right3-wrapper" class="dfp-tag-wrapper"><div id="dfp-ad-right3" class="dfp-tag-wrapper impview impview">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("dfp-ad-right3");
});
</script>
</div></div></div></div><div id="block-ibtimes-picks-hp-latest-news" class="block block-ibtimes-picks" data-gtm-action="Left_Column"><div class="content"><div class="block-title"> Latest News</div><div class="feature3"> <article class="item-1"><div class="image"><a href="/what-comes-next-approved-brexit-trade-deal-3109175"><picture width="385" height="257" class="mapping-small lazysize"><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/12/24/johnson-scored-a-thumping-majority-in-a-december.jpg 1x" media="(min-width: 1200px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/12/24/johnson-scored-a-thumping-majority-in-a-december.jpg 1x" media="(min-width: 992px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/mobile/public/2020/12/24/johnson-scored-a-thumping-majority-in-a-december.jpg 1x" media="(min-width: 768px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/tablet/public/2020/12/24/johnson-scored-a-thumping-majority-in-a-december.jpg 1x" media="(min-width: 481px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/mobile/public/2020/12/24/johnson-scored-a-thumping-majority-in-a-december.jpg 1x" media="(min-width: 0px)" /><!--[if IE 9]></video><![endif]--><img width="385" height="257" class="mapping-small lazysize lazyload" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/12/24/johnson-scored-a-thumping-majority-in-a-december.jpg" alt="Johnson scored a thumping majority in a December general election on a simple pledge to &quot;get Brexit done&quot;Â " title="" /></picture><meta itemprop="url" content="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/12/24/johnson-scored-a-thumping-majority-in-a-december.jpg"><meta itemprop="width" content="385"><meta itemprop="height" content="257"></a></div><div class="title"><a href="/what-comes-next-approved-brexit-trade-deal-3109175">What&#039;s Next For The Brexit Trade Deal?</a></div> </article> <article class="item-2"><div class="image"><a href="/yes-norad-will-continue-tracking-santa-during-pandemic-3098523"><picture width="385" height="257" class="mapping-small lazysize"><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/12/09/a-boy-wears-a-santa-hat-and-mask.jpg 1x" media="(min-width: 1200px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/12/09/a-boy-wears-a-santa-hat-and-mask.jpg 1x" media="(min-width: 992px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/mobile/public/2020/12/09/a-boy-wears-a-santa-hat-and-mask.jpg 1x" media="(min-width: 768px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/tablet/public/2020/12/09/a-boy-wears-a-santa-hat-and-mask.jpg 1x" media="(min-width: 481px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/mobile/public/2020/12/09/a-boy-wears-a-santa-hat-and-mask.jpg 1x" media="(min-width: 0px)" /><!--[if IE 9]></video><![endif]--><img width="385" height="257" class="mapping-small lazysize lazyload" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/12/09/a-boy-wears-a-santa-hat-and-mask.jpg" alt="A boy wears a Santa hat and mask while looking for a Christmas tree at a farm in Harrowsmith, Ontario, Canada, on December 5, 2020" title="" /></picture><meta itemprop="url" content="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/12/09/a-boy-wears-a-santa-hat-and-mask.jpg"><meta itemprop="width" content="385"><meta itemprop="height" content="257"></a></div><div class="title"><a href="/yes-norad-will-continue-tracking-santa-during-pandemic-3098523">NORAD Is Busy During The Pandemic, But Not Too Busy To Track Santa</a></div> </article> <article class="item-3"><div class="image"><a href="/pound-jumps-expected-brexit-trade-deal-3108854"><picture width="385" height="257" class="mapping-small lazysize"><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/12/23/the-pound-and-stocks-have-rallied-on-expectations.jpg 1x" media="(min-width: 1200px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/12/23/the-pound-and-stocks-have-rallied-on-expectations.jpg 1x" media="(min-width: 992px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/mobile/public/2020/12/23/the-pound-and-stocks-have-rallied-on-expectations.jpg 1x" media="(min-width: 768px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/tablet/public/2020/12/23/the-pound-and-stocks-have-rallied-on-expectations.jpg 1x" media="(min-width: 481px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/mobile/public/2020/12/23/the-pound-and-stocks-have-rallied-on-expectations.jpg 1x" media="(min-width: 0px)" /><!--[if IE 9]></video><![endif]--><img width="385" height="257" class="mapping-small lazysize lazyload" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/12/23/the-pound-and-stocks-have-rallied-on-expectations.jpg" alt="The pound and stocks have rallied on expectations Britain and the European Union will soon announce a post-Brexit trade deal" title="" /></picture><meta itemprop="url" content="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/12/23/the-pound-and-stocks-have-rallied-on-expectations.jpg"><meta itemprop="width" content="385"><meta itemprop="height" content="257"></a></div><div class="title"><a href="/pound-jumps-expected-brexit-trade-deal-3108854">Pound Jumps On Expected Brexit Trade Deal</a></div> </article> <article class="item-4"><div class="image"><a href="/these-8-stores-are-open-christmas-day-2020-3101919"><picture width="385" height="257" class="mapping-small lazysize"><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/11/19/starbucks-plans-to-lift-wages-for-us-employees.jpg 1x" media="(min-width: 1200px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/11/19/starbucks-plans-to-lift-wages-for-us-employees.jpg 1x" media="(min-width: 992px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/mobile/public/2020/11/19/starbucks-plans-to-lift-wages-for-us-employees.jpg 1x" media="(min-width: 768px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/tablet/public/2020/11/19/starbucks-plans-to-lift-wages-for-us-employees.jpg 1x" media="(min-width: 481px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/mobile/public/2020/11/19/starbucks-plans-to-lift-wages-for-us-employees.jpg 1x" media="(min-width: 0px)" /><!--[if IE 9]></video><![endif]--><img width="385" height="257" class="mapping-small lazysize lazyload" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/11/19/starbucks-plans-to-lift-wages-for-us-employees.jpg" alt="Starbucks plans to lift wages for US employees by at least 10 percent" title="" /></picture><meta itemprop="url" content="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2020/11/19/starbucks-plans-to-lift-wages-for-us-employees.jpg"><meta itemprop="width" content="385"><meta itemprop="height" content="257"></a></div><div class="title"><a href="/these-8-stores-are-open-christmas-day-2020-3101919">Some Stores Remain Open On Christmas</a></div> </article> <article class="item-5"><div class="image"><a href="/home-holidays-see-christmas-lights-world-these-5-virtual-tours-3109094"><picture width="385" height="257" class="mapping-small lazysize"><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2016/12/01/rockefeller-christmas-tree.JPG 1x" media="(min-width: 1200px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2016/12/01/rockefeller-christmas-tree.JPG 1x" media="(min-width: 992px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/mobile/public/2016/12/01/rockefeller-christmas-tree.JPG 1x" media="(min-width: 768px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/tablet/public/2016/12/01/rockefeller-christmas-tree.JPG 1x" media="(min-width: 481px)" /><source data-srcset="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/mobile/public/2016/12/01/rockefeller-christmas-tree.JPG 1x" media="(min-width: 0px)" /><!--[if IE 9]></video><![endif]--><img width="385" height="257" class="mapping-small lazysize lazyload" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2016/12/01/rockefeller-christmas-tree.JPG" alt="Rockefeller christmas tree" title="" /></picture><meta itemprop="url" content="https://s1.ibtimes.com/sites/www.ibtimes.com/files/styles/sm/public/2016/12/01/rockefeller-christmas-tree.JPG"><meta itemprop="width" content="385"><meta itemprop="height" content="257"></a></div><div class="title"><a href="/home-holidays-see-christmas-lights-world-these-5-virtual-tours-3109094">These 5 Virtual Tours Will Take You Around The World For The Holidays</a></div> </article></div></div></div><div id="" class="block block-fusion-ads"><div class="content"><div id="dfp-ad-right4-wrapper" class="dfp-tag-wrapper"><div id="dfp-ad-right4" class="dfp-tag-wrapper impview impview">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("dfp-ad-right4");
});
</script>
</div></div></div></div><div id="block-fusion-lemon-social-capital-latest-news" class="block block-fusion-lemon"><div class="content"><div class="social_capital_block"> <section class="card box-contents box-quote"><div class="box-title"><div><a href="/social-capital">Social Capital</a></div><div class="social_capital_sub1">Trail Blazing CEOs</div><div class="social_capital_sub2">Redefining Business Success</div></div> <article class="writer-opinion writer-opinion-large"><h3 class="title-reporter"><a href="/social-capital-ultimate-gift-america-3107337" class="article-link">Social Capital: The Ultimate Gift To America </a></h3> </article> <article class="writer-opinion writer-opinion-large"> <a href="/profile/austen-allred"><img src="https://d1.spcdn.ibt.com/multiupload/2020/12/17/austen-allred.png" alt="Austen Allred"></a><div class="reporter"><a href="/profile/austen-allred">Austen Allred</a></div><h3 class="title-reporter"><a href="/austen-allred-broke-down-biggest-barrier-higher-education-3102896" class="article-link">Austen Allred Broke Down The Biggest Barrier To Higher Education</a></h3> </article> </section></div><style>
.social_capital_block, .spotlight_block{margin-bottom:25px}.social_capital_block .box-title{padding:12px 0;font-size:24px;text-align:center;font-weight:700;line-height:1;color:#fff;background:#000}.social_capital_sub1{margin-top:10px;font-size:15px}.social_capital_sub2{margin-top:10px;font-size:14px}.writer-opinion{margin-top:20px;padding:15px;padding-top:0;position:relative}.writer-opinion:before{content:'';position:absolute;z-index:-1;left:0;top:56px;right:0;bottom:0;background:#f7f7f7}.writer-opinion>a{display:inline-block;vertical-align:middle;text-align:center;line-height:82px;font-size:29px;margin-right:10px;width:82px;height:82px;border-radius:50%;overflow:hidden;position:relative;color:#0065cc;color:#000;background:#e9e9e9}.writer-opinion>a>img{position:absolute;left:50%;top:50%;transform:translate(-50%,-50%)}@supports (object-fit:cover) or (-o-object-fit:cover){.writer-opinion>a>img{object-fit:cover;width:100%;height:100%}}.writer-opinion .reporter{display:inline-block;vertical-align:middle;font-size:16px;font-weight:700;color:#000}.writer-opinion h3{font-size:14px;font-weight:500;line-height:1.3;color:#000;margin:0;padding-top:10px}
</style></div></div> </aside></div><div class="page-bottom"><div id="fb-root"></div><div id="dfp-ad-oop1-wrapper" class="dfp-tag-wrapper"><div id="dfp-ad-oop1" class="dfp-tag-wrapper">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("dfp-ad-oop1");
});
</script>
</div></div><div id="dfp-ad-oop2-wrapper" class="dfp-tag-wrapper"></div><div id="dfp-ad-oop3-wrapper" class="dfp-tag-wrapper"><div id="dfp-ad-oop3" class="dfp-tag-wrapper">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("dfp-ad-oop3");
});
</script>
</div></div></div></div> </main><div id="block-ibtimes-footer-ibtimes-footer" class="block block-ibtimes-footer" data-gtm-action="Footer"><div class="content"> <footer class="page-footer"><div class="container-fluid"><div class="flex-md jc-sb ai-c"><div class="about_menu_links"><h2>IBT</h2><ul class="links"><li class="menu-2453 first"><a href="https://corp.ibt.com/brands" target="_blank">About Us</a></li><li class="menu-2452"><a href="https://corp.ibt.com/advertising" target="_blank">Advertise with Us</a></li><li class="menu-2829"><a href="/media-kit" target="_blank">Media Kit</a></li><li class="menu-2454"><a href="https://corp.ibt.com/about-terms-services" target="_blank">Terms &amp; Conditions</a></li><li class="menu-2455"><a href="https://corp.ibt.com/about-privacy-policy" target="_blank">Privacy Policy</a></li><li class="menu-9520 last"><a href="https://corp.ibt.com/about-cookie-policy" target="_blank">Cookie Policy</a></li></ul></div><div class="editions_menu_links flex-md ai-c"><h2>Editions</h2><ul class="links"><li class="menu-789 first"><a href="http://www.ibtimes.com.au" title="business news australia" target="_blank">Australia</a></li><li class="menu-797"><a href="http://www.ibtimes.co.in" title="business news india" target="_blank">India</a></li><li class="menu-7737"><a href="http://www.ibtimes.sg" title="business news singapore">Singapore</a></li><li class="menu-804"><a href="http://www.ibtimes.co.uk" title="business news uk" target="_blank">United Kingdom</a></li><li class="menu-805 last"><a href="http://www.ibtimes.com" title="business news us">United States</a></li></ul></div></div><div class="flex-sm jc-sb ai-c"><div class="copyright">&copy; Copyright 2020 IBTimes LLC. <span>All Rights Reserved.</div><div class="social flex-xs ai-c"> <a class="genericon genericon-facebook-alt" href="https://www.facebook.com/IBTimes" target="_blank" rel="nofollow" title="Facebook"></a> <a class="genericon genericon-twitter" href="https://twitter.com/ibtimes" target="_blank" rel="nofollow" title="Twitter"></a> <a class="genericon genericon-linkedin" href="https://www.linkedin.com/company/international-business-times" target="_blank" rel="nofollow" title="LinkedIn"></a> <a class="genericon genericon-tumblr" href="https://ibtimes.tumblr.com" rel="nofollow" target="_blank" title="Tumblr"></a></div></div></div></footer><div class="scroll-top"></div></div></div><!--[if lte IE 9]>
<script type="text/javascript" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/advagg_js/js__Gyt98BNZBp62Hdp7ubSwvRKn1TtNmpkY-X5lIrn-rnw__VVfZji-D_VzFHWjho2-OtNHEFXIgpt1awGvCFLcx49A__XiWFjKoCIpGXBnLBEV6VO5BllK1Eni70YhEwwh7CFkc.js#ie9-" onload="if(jQuery.isFunction(jQuery.holdReady)){jQuery.holdReady(true);}"></script>
<![endif]--><!--[if gt IE 9]>
<script type="text/javascript" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/advagg_js/js__Gyt98BNZBp62Hdp7ubSwvRKn1TtNmpkY-X5lIrn-rnw__VVfZji-D_VzFHWjho2-OtNHEFXIgpt1awGvCFLcx49A__XiWFjKoCIpGXBnLBEV6VO5BllK1Eni70YhEwwh7CFkc.js#ie10+" defer="defer" onload="if(jQuery.isFunction(jQuery.holdReady)){jQuery.holdReady(true);}"></script>
<![endif]--><!--[if !IE]><!-->
<script type="text/javascript" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/advagg_js/js__Gyt98BNZBp62Hdp7ubSwvRKn1TtNmpkY-X5lIrn-rnw__VVfZji-D_VzFHWjho2-OtNHEFXIgpt1awGvCFLcx49A__XiWFjKoCIpGXBnLBEV6VO5BllK1Eni70YhEwwh7CFkc.js" defer="defer" onload="if(jQuery.isFunction(jQuery.holdReady)){jQuery.holdReady(true);}"></script>
<!--<![endif]-->
<script type="text/javascript" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/advagg_js/js__L9T9MMhD4LjvhcuxbWhNp7dB0VOAKyD3X9nWHmhjY4Q__E-YCd_HO3bT_lM9iSiqLVO-fzD5c-3rTbipbwfZlqLA__XiWFjKoCIpGXBnLBEV6VO5BllK1Eni70YhEwwh7CFkc.js" defer="defer" onload="function advagg_mod_1(){advagg_mod_1.count=++advagg_mod_1.count||1;try{if(advagg_mod_1.count<=40){init_drupal_core_settings();advagg_mod_1.count=100}}catch(e){if(advagg_mod_1.count>=40){throw e}else window.setTimeout(advagg_mod_1,1)}}
function advagg_mod_1_check(){if(window.init_drupal_core_settings&&window.jQuery&&window.Drupal){advagg_mod_1()}else window.setTimeout(advagg_mod_1_check,1)};advagg_mod_1_check();"></script>
<script type="text/javascript" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/advagg_js/js__CcWIFRDSoUxnsdQz_WJ0oTQqrcb7XPj2j0oxIjRlshg__BFPC4pD9NASs64GdyPmkOAkDQZqqjeTBJ8uO_TfxHtE__XiWFjKoCIpGXBnLBEV6VO5BllK1Eni70YhEwwh7CFkc.js" defer="defer"></script>
<script type="text/javascript" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/advagg_js/js__K8ArvkXR4ILCClr7YJ4pnHFJpRuFieZm33dzKb4NAkk__Vl6VhIdVdT-zjZg6mXaqAReqE8gDqKLqGIWvWzt4MUw__XiWFjKoCIpGXBnLBEV6VO5BllK1Eni70YhEwwh7CFkc.js" defer="defer"></script>
<script type="text/javascript" src="https://s1.ibtimes.com/sites/www.ibtimes.com/files/advagg_js/js__GDmBXk7s7e53EwQ2zRQ8HTLc8TQVON8Gp1UB5Qkk1O4__DT1dsF4tD_mOsi9X5h0qP04PpbXXFu8AfyZZW4BE3NU__XiWFjKoCIpGXBnLBEV6VO5BllK1Eni70YhEwwh7CFkc.js" defer="defer"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
function init_drupal_core_settings() {jQuery.extend(Drupal.settings,{"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"us_ibtimes","theme_token":"Y1q9XP-_CiiGQaT7LqG2hT3G2fMPrKgsfL3o1TR-GHg"},"colorbox":{"opacity":"0.85","current":"{current} of {total}","previous":"\u00ab Prev","next":"Next \u00bb","close":"Close","maxWidth":"98%","maxHeight":"98%","fixed":true,"mobiledetect":true,"mobiledevicewidth":"480px"},"connatix":{"sticky":1,"mobsticky":1},"1world":{"move_bottom_ads":1},"urlIsAjaxTrusted":{"":true},"ibtmediaDfp":{"debug":false,"yeildbot":0,"rubicon":0,"site_url":"www.ibtimes.com"},"tm":{"tm":{"title":"How+To+Cook+A+Standing+Rib+Roast","category":"Media+%26+Culture","category_id":"1630","category_url":"https%3A%2F%2Fwww.ibtimes.com%2Fmedia-culture","story_type":"article","created":"1608819947","uid":"454064","image":"https%3A%2F%2Fs1.ibtimes.com%2Fsites%2Fwww.ibtimes.com%2Ffiles%2Fstyles%2Fthumbnail%2Fpublic%2F2020%2F12%2F24%2Fprime-rib-roast.jpg","syndication":1,"site":"www.ibtimes.com","id":"3109100","url":"https%3A%2F%2Fwww.ibtimes.com%2Fhow-cook-prime-rib-christmas-6-easy-steps-3109100"},"settings":{"st":1608830831,"track_url":"https:\/\/feeds.ibt.com\/track.gif"}},"advagg_font":[],"advagg_font_storage":1,"advagg_font_cookie":1,"advagg_font_no_fout":0,"contentCorrection":{"nodeId":"3109100","correctionFormNodeId":"1696672","correctionFormNodetitle":"How To Cook A Prime Rib For Christmas In 6 Easy Steps  ","correctionFormNodeCategory":"\u003Ca href=\u0022\/media-culture\u0022\u003EMedia \u0026amp; Culture\u003C\/a\u003E","correctionFormConfirmationMsg":"\u003Ch3\u003EThank you\u003C\/h3\u003E\u003Cp\u003EYour correction has been received and will be reviewed as soon as possible. IBTimes welcomes your feedback on any item that warrants correction.\u003C\/p\u003E","correctionFormNodeURl":"https:\/\/www.ibtimes.com\/how-cook-prime-rib-christmas-6-easy-steps-3109100"},"fusion_jwplayer":{"adtag":"https:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=640x360\u0026iu=\/43459271\/video.us.ibtimes\/nonpromoted\u0026env=vp\u0026gdfp_req=1\u0026impl=s\u0026unviewed_position_start=0\u0026hl=en\u0026output=xml_vast3\u0026url=__page-url__\u0026description_url=http%3A%2F%2Fwww.ibtimes.com\u0026correlator=__timestamp__","adtagVars":"","preslate":0,"autostart":true,"autostart_embed":0,"title":"\u0027Christmas At The Castle\u0027- It\u0027s A Wonderful Lifetime 2020 Preview","init":true,"site":"IBT","logo":"","bg":"#79CE00","unblocker":"","unblocker_ad":"","mediaid":"517834","playlist":"https:\/\/videos.ibtimes.com\/widget\/play-list?nid=517834\u0026items=7","mobileautoplay":1,"autoplay_viewable":0,"mobilesticky":1,"displaytitle":0,"debug":0,"primary":"html5","vpaidmode":"insecure","repeat":0,"stretching":"fill","player_src":"","video_image":"https:\/\/dc.newsweek.com\/en\/full\/2034292\/christmas-castle.jpg?w=480\u0026h=270\u0026q=55\u0026f=ae17ec8bb99815d8f76c434942bd75db"},"dataLayer":{"languages":{"en":{"language":"en","name":"English","native":"English","direction":0,"enabled":1,"plurals":0,"formula":"","domain":"","prefix":"","weight":0,"javascript":""}}},"ibtimes":{"page_url":"https:\/\/www.ibtimes.com\/how-cook-prime-rib-christmas-6-easy-steps-3109100"}});
if(jQuery.isFunction(jQuery.holdReady)){jQuery.holdReady(false);}} if(window.jQuery && window.Drupal){init_drupal_core_settings();}
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
function advagg_mod_2(){advagg_mod_2.count=++advagg_mod_2.count||1;try{if(advagg_mod_2.count<=40){(function(document,window){var script=document.createElement("script");script.type="text/javascript";script.src="https://api.pushnami.com/scripts/v1/pushnami-adv/5eff8cfa4b5f601334e201d0";script.onload=function(){Pushnami.update({category:"Media & Culture",tag:"",topic:"Christmas"}).prompt()};document.getElementsByTagName("head")[0].appendChild(script)})(document,window);advagg_mod_2.count=100}}catch(e){if(advagg_mod_2.count>=40){throw e}else window.setTimeout(advagg_mod_2,250)}}
function advagg_mod_2_check(){if(window.jQuery&&window.Drupal&&window.Drupal.settings){advagg_mod_2()}else window.setTimeout(advagg_mod_2_check,250)};advagg_mod_2_check();
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=263851690471857&version=v3.1";fjs.parentNode.insertBefore(js,fjs)}(document,'script','facebook-jssdk'));
//--><!]]>
</script>
</body>
</html>